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System Requirements
Safe at Last! for Macintosh requires MacOS 10.3.9 or later.  Safe at Last! for Windows requires 
Windows XP or later.

A color monitor of 1024 x 768 pixels or larger is required.

Installation
Macintosh
To install Safe at Last! on a Macintosh, insert the CD in the drive.  Double-click the installer 
icon to begin the process.  The installer places Safe at Last! and the Safe at Last! User’s guide 
inside the Marblesoft folder in your Applications folder.  It will create a Marblesoft folder if none 
exists, and it will create an alias on your desktop. You can drag the alias to your Dock if you 
prefer.

Windows
To install Safe at Last! on Windows, insert the CD in the drive.  The installer should start 
automatically.  If you have turned off the auto-start feature, double-click the SETUP.EXE icon to 
begin the process.  The installer places Safe at Last! and the Safe at Last! User’s guide inside the 
Marblesoft folder in your Program Files folder.  It will create a Marblesoft folder if none exists, 
and it will add Safe at Last! and the User’s Guide to your Start menu.

Running the Program
Macintosh
To launch Safe at Last!, double-click the icon on your desktop, or click the icon in your Dock.  If 
you have deleted these aliases, or if you’re launching the program from a different user account, 
open your Applications folder, then the Marblesoft folder, then the Safe at Last! folder.  Double 
click the Safe at Last! icon to start the program.

Windows
To launch Safe at Last!, select it from the Marblesoft folder in the Start menu.  If you have 
deleted this shortcut, open your Program Files folder, then the Marblesoft folder, then the Safe at 
Last! folder.  Double click the Safe at Last! icon to start the program.
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Menus
The program’s menu bar can be hidden or shown at any time. Press the “ESC” key to hide or 
show the menu bar. All the program settings and features can be controlled from the menu bar.  
You can also use keyboard shortcuts to access most menu items, even when the menu bar is 
hidden.

File Menu
Use the File Menu to play a new game or to change levels prior to any points being scored. 

Options Menu
Use the Options menu to change the player name, or to change the input/scanning settings.  

Help Menu
Use the Help menu for general instructions on the game or on the input method being used.



Safe at Last! User’s Guide	 �

Playing the Game
Safe at Last! is a strategy game specially designed for students with special needs.  It is intended 
for older children and adults. 

The object of the game is to successfully reveal all the safe squares in a grid that also contains 
some hazards to be avoided.  The player uses deductive reasoning to determine the safe squares. 
The player proceeds through the grid, revealing one square at a time until the entire grid is 
cleared.  If a hazard is revealed, the game is over.

Once a square has been revealed, if it does not contain a hazard, it will be replaced by a number.  
That number is the number of adjacent squares, up, down, across or diagonally, that contain a 
hazard.  (A blank square indicates that no adjacent squares contain a hazard.)   

Consider the following example:  (To follow this example on screen, select “Tutorial Game” 
from the File menu.)

The player has clicked in square A, revealing the number 1, which means that one and only one 
of the adjacent squares, B, E or F, contains a hazard.  We have nothing definitive, yet, so we still 
need to guess. Let’s guess that square E is safe, and click there.

Note: It is a good idea to start the game by revealing one or more of the four corners. The 
corners are the best squares to try first because you can more often reveal solvable squares.  
In the above example, it would be mathematically best to try one of the other three corners.  
However, for the purposes of this tutorial, we are going to try square E.
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The next screen shows squares A and E revealed, each containing a 1.  Now we have enough 
information to logically make the next move.  From the 1 in square A, we know that either B 
or F contains a hazard.  Since either B or F contains a hazard, and they both touch E, we know 
that the one hazard to satisfy the 1 in square E must be in either B or F.  That means that I and 
J must both be safe. Need proof?  If I or J contains a hazard, E says there cannot be one in B or 
F, making it impossible for A to touch one hazard. So now we need to reveal the safe squares I 
and J.

After clearing I and J, we see the next screen. We can now identify the first hazard. Square I 
needs one adjacent hazard, and there is only one unrevealed square adjacent, F, so the hazard 
must be there.  Since a hazard in F also satisfies A and E, we know that B is safe.  The proof?  If 
B contains a hazard, A and E say that F must be safe, and that would be impossible because of 
the hazard needed by I.
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Before clearing B, we’ll put a flag in square F to remind us that it has a hazard.  We’ll discuss 
how to do that later.  The above example shows the screen after we put a flag in F and clear B.  
Now we’re getting somewhere. B is satisfied by the one hazard in F, so C and G are clear.  Lets 
reveal them next.

We can learn a lot from this screen.  First, continuing the logic we’ve been using, we can see that 
F satisfies the 1 for square C, making D and H safe.  But we can also see that the 2 hazards that 
are needed by J can only be in F and K.  Lets mark K with another flag, while clearing D and H.
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That leaves only one square to solve.  We can see that G is satisfied by F and K, so L must be 
clear.  You can also see that K satisfies H, again showing that L is safe.  Finally, you can see by 
the “Safe Squares” count that there is still one remaining safe square.

By the way, did you notice the blank square in D?  That means there are 0 surrounding hazards, 
as you can clearly see. More about that later.  For now, lets clear L and win the game.



Safe at Last! User’s Guide	 11

Marking Hazards
If you know a square contains a hazard, you can mark it with a flag, as we did in squares F and K 
in the previous example.  If you’re unsure, you can mark a square with a question mark.  

In the above example, we know that either E or F must contain a hazard to satisfy I.  We can 
mark these squares with a question mark to show that one of them has a hazard, but we don’t 
know which. We’ll show you how to mark squares a little bit later.

It is easier to deduce the contents of a square when the surrounding hazards are marked. 
However, you do not need to mark hazards to solve the game.  In fact, the fewer hazards you 
mark, the more points you will score.

Levels of Difficulty
After each game, a screen like this one will appear.

If the previous game was won, there will be an option to play a harder level.  If the previous 
game was lost, there will be an option to play an easier level.
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Input Options
Safe at Last! provides several ways that a player can input their choices.  The simplest and fastest 
are direct selection with a mouse, touch screen or keyboard.  For players who cannot use the 
mouse or keyboard, scanning allows the user to input using one, two or three switches.

To change the input options, choose Input Options from the Options menu, or type (Mac: ⌘I or 
Win: Ctrl+I).  A dialog something like this one will appear:

Direct Selection
Direct selection allows the user to directly clear or mark a square with a mouse, keyboard or 
other pointing device.  Direct selection with a mouse, touchscreen or similar device is the fastest 
for those players who can use it.  Simply click on a square to clear it.  To mark or unmark a 
square with a flag or question mark, hold down the CTRL key while you click.

Another direct selection option is to use the keyboard.  When keyboard selection is on, a 
rectangle marks the current square.  Use the arrow keys to move the rectangle up, down, right 
or left.  When the rectangle is on the square you want, press RETURN or ENTER to select it, or 
press the TAB key or space bar to mark or unmark the square.

In the above example, the player has just cleared square L by pressing RETURN. The up arrow 
will now move the cursor up to square H, and the left arrow will move it left to square K.

When keyboard selection is on, you can still use the mouse for direct selection.
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Scanning
In scanning mode, the computer will scan all possible plays for the player.  The player can 
move to a different square by pressing a switch. When the player has selected a target square, 
the computer will display several different icons in that square.  When the player hits the switch 
while the green arrows are displayed, the program will scan to the next square.  When “OK” 
is selected, the program will reveal the square.  When a flag or question mark is selected, the 
computer will mark the square with the selected icon.

To change the scanning options, choose Scanning Options from the Options menu, or type (Mac: 
⌘Y or Win: Ctrl+Y).  A dialog something like this one will appear:

Select the number of switches, type of scanning, and the scan rate (for timed scanning). The 
player can use one, two or three switches to control the program.

There are two basic methods of scanning in Safe at Last! - Timed Scanning and Step Scanning, 
and two types of scanning with each method - Sequential Scanning and Random Scanning. With 
timed scanning, the computer scans the available choices at the scan rate you have chosen.  With 
step scanning, the student uses two or more switches to scan the choices and make a selection.

The “Draw ‘Quit’ button” option causes a Quit button to be drawn on the pre-game screen, 
allowing switch users to quit the program.
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Sequential Scanning
In Sequential Scanning, the computer will scan each row of squares.  When the player selects 
a row, the computer will start scanning each square within the row.  The player then selects the 
square they want to play.  

   

The example on the left shows sequential scanning a row.  The right side shows sequential 
scanning after the row has been selected.  The green arrows indicate that a selection will move 
the cursor.  In this case, hitting the selection switch would cause the cursor to move to square C.

Random Scanning
In Random Scanning, the computer will randomly scan to all playable squares.  However, the 
program will favor the squares most likely to be played.

   

The example on the left shows random scanning on square I. When the green arrows are 
displayed, hitting the switch causes the cursor to move to another random square.  The right 
side shows another square after scanning to square D. Hitting the switch while the “OK” icon is 
displayed will cause the square to be revealed.
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One Switch Scanning
When using a single switch for timed scanning, the computer will scan at the rate specified in the 
Scanning Options dialog.  The student uses the switch to select the desired icon.  

Configure your switch interface to send a mouse click, space bar, RETURN character, number 
“1” or letter “Y” when the switch is pressed. The same keys on the keyboard can also be used as 
“switches”.

Two Switch Scanning
When using two switch timed scanning, the program operates like single switch scanning, but the 
player can also use the second switch to scan.  When the Step Scanning option is turned on, the 
student must use the second switch to scan (the scan rate does not apply).  

Configure your switch interface to send a mouse click, RETURN character, number “1” or letter 
“Y” when switch #1 is pressed. Configure your switch interface to send a right-click, space 
bar, TAB character, number “2” or letter “N” when switch #2 is pressed. The same keys on the 
keyboard can also be used as “switches”.

Three Switch Scanning
With three switch scanning, the student uses an optional third switch to change the flashing icon. 
Switch #2 moves the cursor to the next square, and switch #1 selects the target square.  With 
timed scanning, the computer will auto-scan at the specified scan rate, acting exactly like the 
third switch.  Three-switch scanning is actually the easiest and most effective way for a two-
switch user to play the game - two switches plus timed auto scanning in effect gives the player 
three switches.

When the Step Scanning option is turned on, the student must use the third switch to scan (the 
scan rate does not apply).  

Configure your switch interface to send a mouse click, RETURN character, number “1” or letter 
“Y” when switch #1 is pressed. Configure the interface to send a TAB character or number “2” 
when switch #2 is pressed. Configure the switch interface to send a right-click, space bar, number 
“3” or letter “N” when switch #3 is pressed.
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Preferences
To change general game preferences, choose “Preferences” from the Safe at Last! menu on a 
Macintosh, or from the Edit menu on Windows, or type (Mac: ⌘, or Win: Ctrl+,). A dialog like 
this one will appear:

Difficulty - Easy or Hard.  In easy mode, fewer hazards are placed on each level. Also, a 
number is circled if it matches the number of unrevealed squares around it.  For example, on the 
following screen the circle in square I indicates that its one hazard can be identified (in square F).

First guess is always safe - Check this box to make the player’s first guess a safe square every 
time. When the check box is off, the player’s first guess could reveal a hazard, and the game 
would be over.  

Automatically reveal safe corners - Check this box to make the computer automatically start each 
game by playing some safe corners.  This speeds up the play considerably, especially for switch 
users.
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Hazard - You can choose the hazard you wish to avoid, from a list of animals or other dangers.  
You can also choose “Random Animals” to change the hazard to a different animal on every 
game.

Colors - You can specify any color for the background, text, tile and highlight colors to make the 
game easier for students with vision difficulties.

Draw 0 on empty squares - This check box causes a 0 to be drawn on squares that have no 
surrounding hazards.

Start each game on level - Set this number to the level on which to begin each game.  Use this 
option for players who are bored with the lower levels.
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Strategy
There are lots of strategies you can employ to solve Safe at Last!  Here are some of the simpler 
ones.

Easy Mode
In easy mode, place a flag in every square adjacent to a circled number. In the following 
example, the circles in squares I and J indicate that we should place flags in F and K.

Corners
Many players like to start the game by revealing the corners.  Many times it’s easy to figure out 
squares in a corner, because there are fewer possibilities to consider.

Adjacent Squares
It’s always easier to solve adjacent squares than scattered squares.  If you are at a point where 
you have to guess, guess a square that touches another already revealed square.
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1s
Squares containing the number 1 are usually the easiest to solve.  Look for 1s in a corner, like 
square I above. Also, look for 1s next to other numbers.  In the example below, we can see that C 
requires either B or F to contain a hazard, and that H requires either K or L to contain a hazard. 
Since that would give G its 2 hazards, we know that J is safe.

Edges
Look for multiple squares that border the edge of the puzzle, or that make a perpendicular line to 
another revealed square. Again, in the previous example, we can see that C requires either B or F 
to contain a hazard, and that H requires either K or L to contain a hazard, making J safe.

In the above example, the 2 hazards needed by I have to be in E and F, thus satisfying the 2 
squares for J.  That makes G and H safe.
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Long Runs
Look for long runs of squares in a single column or row. If you can solve one end of the run, you 
can often keep going for a long way.

In the above example, working from left to right, we can see that A requires a hazard in either 
E or F, satisfying B and making G safe.  If G is safe, C requires F and H to be hazards, and E 
is safe.  Working from right to left, D requires a hazard in G or H, meaning that F must be the 
second hazard for C.  F satisfies B, so E and G are safe.  Both C and D require a hazard in H, 
completing the row.
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Tutorial Games
Safe at Last! includes a tutorial game that you can play for practice.  This game was solved 
earlier in the “Playing the Game” section.  We’ll play the same game and solve it a couple 
different ways in this section.

To play the tutorial game, select “Tutorial Game” from the File menu, or type (Mac: ⌘T or 
Win: Ctrl+T).

Tutorial 2
In “Playing the Game”, we started in the upper left.  This time, lets start in the upper right.

Whoa! Because D is a “0” square (blank), clicking in D also reveals the 3 surrounding squares, 
as you can see above. As we learned earlier, B and F must contain a hazard to satisfy C, and K 
and L must contain one for H.  That satisfies G and makes J safe.  Lets mark it.

 

Now look at the Safe Squares count in the above example.  Since we need 5 safe squares, and we 
know that two of them are in B, F, K, and L, we know that A, E and I are safe.  Lets clear those.
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In this example, we can see that J requires F and K to contain hazards.  Mark them.

Finally, we see that B and C are safe!
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Tutorial 3
Many players like to start by playing all four corners.  Of course, it won’t always work, because 
there may be a hazard in one of the four corners.  But lets try it with the tutorial game and see 
what happens.

Not a bad start. We immediately see that we have a hazard in K, and one in either B or F.  That 
means that J is safe.  Lets mark K and clear J.

Since we know that B or F contain a hazard, we know that A is satisfied, so we can mark E as 
safe. That makes F the hazard to satisfy I and J.  Lets mark those two squares.
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Finally, we can see that B is safe.

For the remaining tutorial games, we’ll give you the order of squares to clear.  It’s up to you to 
determine how you can determine the specified moves in the specified order. Feel free to flag the 
known hazards as you go.

Tutorial 4
D-B-A-E-I-J-L

Tutorial 5
I-E-A-B-C-G-D-J-L
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Tech Support
Contact Marblesoft Technical Support if you have problems installing or running Safe at Last!

Marblesoft Technical Support 
12301 Central Ave NE 
Suite 205 
Blaine, MN 55434

Phone
763-502-0440 

e-mail 
support@marblesoft.com.




